Share article

facebook Share likedin Share Twitter Share

Beta Contextualization Packages

Alongside the OpenNebula 5.8 Beta 2 release, we are also publishing the 5.7.80 beta contextualization packages for the guest operating systems running in the virtual machines. Follow the download pages with the detailed release notes for Linux (and FreeBSD) and Windows. Packages are compatible with OpenNebula versions between 4.6 and 5.8 Beta 2.

You should use these packages if you want to try the very new features of OpenNebula 5.8 Beta. Namely, the LXD hypervisor or multiple managed IP addresses on a single vNIC. Naturally, there are also small fixes and improvements for the users of current stable OpenNebula versions.

With this beta version, we are excited to announce initial support for the FreeBSD guests! It’s now possible to run the FreeBSD virtual machines in the OpenNebula cloud and configure the network, SSH keys, user password, run custom start scripts, or report back via OneGate based on the provided contextualization parameters – most of the things you are used to from the supported Linux distributions. Moreover, we tried to reuse as much as possible from the current Linux contextualization code base. FreeBSD specific contextualization scripts are limited only to the network configuration. The rest of the scripts were adapted to play nicely in both worlds.

For a quick start, we are providing beta KVM images on our Marketplace for FreeBSD 11.2 and FreeBSD 12.0 with preinstalled beta contextualization packages. You can easily import these appliances into your OpenNebula and give it a try.

Please open a GitHub issue to report your bugs or feature requests!

 

Share article

facebook Share likedin Share Twitter Share
Vlastimil Holer

Leave a Reply

Your email address will not be published. Required fields are marked *

eight + one =